Content Violation feature temporarily disabled

Incident Report for Relesys

Postmortem

Postmortem: Content Violation Feature Temporarily Disabled

Date: March 26, 2026
Duration: ~24 hours (approx. 12:49 CET March 25 – resolved March 26)
Impact: Minor — Content Violation screening was temporarily disabled for affected clients. Users could post content without automated policy screening during this period.

Summary

Our Content Violation feature relies on Microsoft Azure's AI Content Safety service for automated content screening. On March 25, Azure experienced instability in this service, causing screening requests to fail intermittently.

Root Cause

Microsoft Azure's AI Content Safety service experienced an outage. Azure was initially slow to report the incident, which delayed our identification of the root cause.

Our Response

Once the issue was identified as Azure-side, we disabled Content Violation screening for affected clients to ensure users were not blocked from posting content. We monitored the situation and began re-enabling the feature once Azure confirmed the service was restored.

Going Forward

We are updating the Content Violation feature to automatically detect when the Azure Content Safety service is unavailable and gracefully handle the situation — reducing response time and minimizing the need for manual intervention in similar scenarios.

Posted Mar 26, 2026 - 10:00 CET

Resolved

The underlying Azure AI Content Safety service has been restored by Microsoft. We will re-enable the Content Violation screening feature on affected clients as soon as possible. Normal operation will resume shortly.
Posted Mar 26, 2026 - 09:52 CET

Update

Azure is still reporting their services to be unavailable. We'll report back when this changes.
Posted Mar 25, 2026 - 15:15 CET

Identified

We are experiencing intermittent issues with our Content Violation feature caused by instability in Microsoft Azure's AI Content Safety service, which we use for automated content screening.

Impact: To ensure that users are not blocked from posting content in the app, we have temporarily disabled the Content Violation screening for affected clients. Content posted while the feature is disabled will not be automatically checked for policy violations.

Next steps: We are monitoring the Azure service and will re-enable the feature as soon as it stabilizes. We will post an update here when the feature is restored.
Posted Mar 25, 2026 - 12:49 CET
This incident affected: Performance App and Management Portal.